Problem updating some DOIs with REST API

I am receiving a strange error when attempting to update some of my DOIs via the REST API.

For example, for the DOI 10.7937/k9/tcia.2015.lo9ql9, any update I issue (for example, this one):

    "data": {
        "attributes": {
            "relatedIdentifiers": [
                                  "relationType": "IsReferencedBy",
                                  "relatedIdentifier": "10.1002/mp.13202",
                                  "relatedIdentifierType": "DOI"

Is met with this error:
{“errors”:[{“source”:“xml”,“uid”:“10.7937/k9/tcia.2015.lo9ql9sx”,“title”:“DOI 10.7937/k9/tcia.2015.lo9ql9sx: No matching global declaration available for the validation root. at line 2, column 0”}]}

Things I have tried:

  • Submitting an empty “xml” field - same error
  • Retrieving the full document and submitting it as an update - same error

I have also tried editing the DOI directly via Fabrica (form) but it won’t let me save the form - it says there is a problem with the “name” field, but there is no name field, nor is any field highlighted in red.

One last thing I tried - I took the full JSON document, changed the state to draft, and added a -2 onto the DOI, and submitted it as a new DOI and it worked without error. This resulting new DOI could also be updated (with the same payload from above) without any errors.

Any ideas what could be going on? This is affecting more than just this DOI for me, there are actually many (though not all).

I think the problem is related to your first author:

      <creatorName>Armato III, Samuel G.</creatorName>

I think Fabrica and/or the API is not parsing correctly the first author name. Due to the “III”.

I think it would be better that you reach so they can keep track of the problem. Please do refer to this post when contacting support.