GraphQL Query Not Returning Expected Dataset

I’m trying link various research outputs together in a network visualization by including ‘Related works’ DOIs in a maDMP from I’ve just added one Related works dataset to the DMP and I’m testing whether it shows up in a GraphQL query to ensure I understand how to link research objects using DMPs but I am not getting the expected results so I’m hoping someone can point out what I’m doing wrong.

I’m following the example here

The .XML file for my maDMP is here. I’ve included the dataset Hakai Institute Juvenile Salmon Program Time Series - Datasets - Hakai Metadata Catalogue as a Related Works in the DMP tool which puts the following relatedIdentifier into the DMP’s Datacite XML file.

    <relatedIdentifier relationType="IsReferencedBy" relatedIdentifierType="URL"> </relatedIdentifier>

When I run the following query (which I got from the example listed above, but removed some sections and replaced the DOI with my own DMP) I get zero associated datasets.

 dataManagementPlan(id: "") {
    name: titles(first:1) {
  datasets: citations(query:"types.resourceTypeGeneral:Dataset") {
        nodes {
          id: doi
          name: titles(first:1)  {

When I run this query but with the original DOI (10.48321/D17G67) provided in the example, I see there are 7 associated datasets, but the Datacite XML file relatedIdentifiers field is constructed the same.

Thanks for any help,

Thanks Brett - I’m tagging @sarala at DataCite who I hope can help

Hi Brett,

The PID Graph currently only counts citations for DOI to DOI connections. Looking at the metadata, the relatedIdentifierType is in your example is “url”, it should be DOI. There is also a problem with the formatting, there appear to be spaces at the beginning and end of the relatedIdentifiers in the metadata. If you resolve these issues you should see the citations appearing. Please contact if you need information and we will be happy to help.

Kind regards,


1 Like